Post Reply 
Tech Support?
02-24-2014, 10:16 PM
Post: #1
Big Grin Tech Support?
So, I tried talking to Blizzard Tech Support but, apparently, they connect you with a live agent who tells what the FAQ section says and, if that doesn't help, they say 'sorry, legacy game, no bueno'.

Which... I mean, yeah, it's a 14 year old game (never mind that I've bougt 5 copies) but... it's just annoying that they offer tech support just to tell you 'we don't offer tech support'. It's a waste of their time and mine. <.<

ANYWAY

This is, in my mind, the go-to place for savvy players so maybe someone here can help.

I'm getting severe in-game lag spikes. These occur in single player, so has nothing to do with my connection. I have a ddwrapper in my game directory to help with the endless compatability issues. I have run the game in compatability mode with all the settings checked (256 colors, 640x480, disable DPI, etc) and I've tried without this and just the ddwrapper. I've even disabled Aero for good measure.

My video drivers are updated and this happens regardless of if I'm running LoD or Eastern Sun (the mod I'm actually interested in playing). I'm running WIndows 7.

I feel like I've tried everything but I really want to get this to work. I finally got my fiancee to agree to play and we were even going to upload some youtube videos for fun but I can't find a way around this.

Any help would be appreciated. ;________;
Find all posts by this user
Quote this message in a reply
02-25-2014, 05:48 AM
Post: #2
RE: Tech Support?
Alright, I seem to have found an... well, at least partial solve. If you right click on the shortcut and go to properties, where it says 'Target' (the same field that you can append with -w to run in windowed mode) you can append -vsync which forces v-Sync and solves about 80% of the 'hanging' issues. It still does it a bit, much much less frequently.

Between Compatibility Mode, a DirectDraw or 3dfxGlide Wrapper and this -vsync mode, I think that will resolve most issues. The options below compatibility mode (640x480 Resolution, Disable Desktop Stuff, etc.) doesn't seem to help at all. So, there you go. We can all add that to our 'list of fixes for D2 on Windows 7'.

Sorry for the double-post, I just thought it was worth noting.

I throw myself to the mercy of the modstaff.
Find all posts by this user
Quote this message in a reply
03-24-2014, 05:54 AM
Post: #3
RE: Tech Support?
It's because you checked all the settings thinking that would help, when in fact that just made it worse.

Use Sven's D2GlideWrapper if you are not using it already or using something else. It's built into D2SE if you like, as is PlugY (inventory size increase). I'll list my settings in Glide that give me ZERO-LAG, even in the Median XL Mod, so you should have no lag at all with classic. I will only list the checked boxes, or the boxes with words. Blank entries and check-boxes will not be listed; btw, I have an NVIDIA GeForce GTX 770 gfx card, and without Glide, game is unplayable laggy:

SETTINGS
Keep Aspect Ratio [x]
VSYNC [x]
fps-limit [no]
static-size [no]
refresh rate [auto]

(do not check anything else!!!)

RENDERER
texture-memory [108-mb] <--set to max
buffer-texture-size [4096x4096] <--set to max
texture for videos [x]
bilinier filtering [x]
supersampling [x]
shader-gama [x]

(do not check anything else!!! do not check 32-bit!)

WRAPPER-STATISTICS
Up to you. I put the clock and texture mass to see when I should lag, but since applying these settings, I don't lag at all anymore so really, I could just get rid of this.

EXTENSIONS
[x] <-- check them all!!! If you don't know what they do, read the help file. Chance are if you have a vid card made within the last ten years, you should check off everything.


And that should be it! Obviously TEST it, and you should see fluid movement of the mouse over the water that shows your framerate. The red, green, blue colors should show definitive blocks of colored shading, not a smooth transition. If all this is true, exit and Glide will have fixed your gfx woes with DII forever, amen! Then just run VidTest in the DII directory and set your video card to Glide and whoola, lag free play. If your test comes out screwed up, then try different settings... it's possible your video card does not support OpenGL, in which case, your sol buddy.

"What good fortune it is for governments that the people they govern do not think." - Adolf Hitler´╗┐
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: