Post Reply 
Weird crash glitch
02-24-2012, 12:10 AM (This post was last modified: 02-28-2012 09:02 PM by ERayz.)
Post: #1
Weird crash glitch
Hello guys.

Today I started running into an issue with D1, more specifically my rogue. I think my file has been corrupted in a way that I cannot fill my inventory without crashing the game.

I was buying potions at Adria, then the game crashed to desktop. At first I thought it was due to the hacker player that just joined the game, but no, it happened in the next game too while buying potions.

Then I tried buying another type of potion, crashed again. Then I tried with scrolls instead, crash again. Then I tried with gold, crashed.

I wanted to see if the game would crash even with inventory opened, and it did crash again. I tried filling my inventory with another character, no problem. After that I tried filling the inventory by ending with another inventory slot; changed nothing, I still crash to desktop.

Then I remembered that when I use DiabloGuard or blue scorpio diablo saver, these programs thought I had a ring (drake's/stars 43/9) in the inv 01 slot, while I had nothing in this slot. However Diabloguard thought I was cheating cause I wear the exact same ring. So I tried to overwrite this ring by importing an amulet with Blue Scorpio at inv 01 slot. Now it detects this amulet instead. But I cannot see it in-game. <--- This part of the issue has been occuring for a while, without causing any gameplay problem, but I still think the problem could be related.

On the Tristram website, this amulet does not appear.

I think the problem is that the inv 01 slot appears as full, but the game itself reads it as empty, so when I fill my inventory, it tries to fill a slot 41 or something.

Anybody ever had this issue? Also, anybody got a solution for me?

EDIT: I narrowed down the problem even more. I can fill my inventory, as long as there is at least one item that uses more than one slot. So this means I had this issue for a while, and just never happened to have my inventory filled with only one-slot items. Now, if there was a way to delete wahtever is in my inv 01 slot, even if it requires me to re-write my save file partly, but I do not know what kind of program would allow me to do this.

EDIT2: I found a solution, and it's A LOT simpler than expected. If there is an item detected by your scanner or muling program, but cannot see it in your inventory, you can sell it to Griswold anyways.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: