Post Reply 
Can only play Diablo 1 by running the 1.09 patch?
11-30-2014, 05:42 AM
Post: #1
Can only play Diablo 1 by running the 1.09 patch?
Hey all!
I've been going crazy trying to set up Diablo 1 on my Windows 8.1 (x64) PC. I tried all compatibility settings, the explorer.exe-killing batch file, various directdraw patches, updating, and everything under the sun, but it still crashes right after I run diablo.exe. (and yes, the CD is in)

BUT, for whatever reason, if I run the 1.09 patch, it installs, and then at the end automatically boots Diablo 1 and it works completely fine! This is the strangest thing I've seen in a while, any ideas? I followed everything under the compatibility sticky on this forum (which was very helpful, thank you OP!)

Help!
Quote this message in a reply
Post Reply 


Messages In This Thread
Can only play Diablo 1 by running the 1.09 patch? - Derf321 - 11-30-2014 05:42 AM

Forum Jump: